Network Automation & Introduction to Postman

Опубликовано: 20 Октябрь 2024
на канале: MKSIT
7,352
159

In today's world network automation is the way to go. Manual networks are not only difficult to manage but difficult to scale. In today's video we look into the world of automation and start with testing REST APIs of new MikroTik RouterOS.

Timeline:
00:00 Introduction
01:05 Network Automation
01:33 Why To Automate?
03:13 What to Automate?
03:49 Road Blocks
05:54 Methods to interact with Device
08:16 Introduction to REST API
09:37 HTTP Methods
10:49 MikroTik Documentation v7.x
11:50 MikroTik install SSL Certificate
15:42 Download and Install Postman (not Demo'd)
16:05 Postman Introduction
16:26 Postman - Create a new Workspace for MikroTik
18:04 Postman - Create environment variables
19:07 Create GET Request
20:35 Create PUT Request
23:20 Create DELETE Request
25:48 Create PATCH Request

Setting up MikroTik Certificate:
/certificate add name=CA common-name=CA key-size=2048 days-valid=3650 key-usage=key-cert-sign,crl-sign
/certificate sign CA ca-crl-host=127.0.0.1
/certificate add name=https common-name=https key-size=2048 days-valid=3650
/certificate sign https ca=CA
/ip service set www-ssl certificate=https

(Note: in case you change any name, make sure you change them here also)