Configuring HSRP and RIPv2, Packet Tracer v.7.2

Опубликовано: 06 Ноябрь 2024
на канале: Saleh Al-Moghrabi (Sal)
708
11

   / mrsaleh970  
https://drive.google.com/file/d/1eAds...
HSRP:
Hot Standby Routing Protocol, is a routing protocol that allows host computers on the internet to use multiple routers that act as a single virtual router, maintaining connectivity even if the first hop router fails, because other routers are on “ hot standby” ready to go.
It is a redundant protocol developed by cisco to provide gateway redundancy without any additional configuration on the end device in the subnet, with HSRP configured between a set of routers, they work in concert to present the appearance of a single virtual router to the hosts on the LAN.
Let us ping from PC-A to PC-C
ping 192.168.1.33 the ping should be successful
Now I will configure RIPv2 on the routers except for the loopback 0 on Router2.
On Router1:
router rip
version 2
network 192.168.1.0
network 10.1.1.0
no auto-summary
On Router2
router rip
version 2
network 10.1.1.0
network 10.2.2.0
no auto-summary
On Router3
router rip
version 2
network 10.2.2.0
network 192.168.1.0
no auto-summary
On Router2 I will configure a default route using Loopback 0 as the exit interface network, and then use the command ( default-information originate), this way it will inject the default route into RIP precisely, to redistribute the default route into RIP process.
ip route 0.0.0.0 0.0.0.0 loopback 0
router rip
default-information originate.
Now from PC-A, I will able to ping all the interfaces in the network.
Now looking at the topology, it has been designed with some redundancy, both PC-A and PC-C are configured with only one gateway address, PC-A using Router1, PC-C using Router3, if either router or interface went down, the PC could lose the connection to the internet.
Let us trace the path to the loopback 0 from PC-A and PC-C
tracert 1.1.1.1
Now, I will start a ping session from PC-A to the loopback on Router2, and then delete the cable between Router1 and SW-1
ping -t 1.1.1.1
I will do the same on PC-C to ping the loopback0 and then delete the cable between Router2 and SW-2
ping -t 1.1.1.1
We will notice the ping fails between the PCs the loopback 0.
Now I will configure HSRP and change the default gateway address on PC-A, PC-C, SW-1 and SW-2, as Router1 becomes the active router via configuration of the HSRP priority command.
On Router1
interface g0/1
standby version 2
standby 1 ip 192.168.1.254
standby 1 priority 150
standby 1 preempt
On Router3
interface g0/1
standby version 2
standby 1 ip 192.168.1.25
On Router1
show standby
show standby brief
Now, I will change the default-gateway on PC-1, PC-2, SW-1 and SW-2 to 192.168.1.254
From PC-1 ping the interfaces of the routers.
• Start a ping session on PC-A and break the connection between the SW-1 and Router1.
ping -t 1.1.1.1
Run the show command
show standby brief on Router1 and Router3
Now we will change the HSRP priority on Router3 to 200
Router3 is still not the active router until we type the command preempt.